Welcome [ B2BiAxis Sign In / Register ]  
Follow Us
  • Page:
  • 1

TOPIC: FTP server refuses to start, says Port 21 already

FTP server refuses to start, says Port 21 already 2 weeks 16 hours ago #7635


I set up an FTP server a few days ago (Cerberus FTP Server). It worked fine for awhile but suddenly I found that no one could connect to the server. It kept saying that software on my host machine had ended the connection. I tried various other FTP server software, and they all gave the same error when I actually tried to put the server online; they claimed that port 21 was already in use. For the record, this FTP server is behind a NAT router using an internal IP address. However, it worked fine for more than day before this issue developed.

I uninstalled all of my FTP software, rebooted multiple times, ran a virus scan to make sure there were no trojans using port 21 (McAfee came up clean), for good measure I ran Ad-Aware and Spybot, and even installed network monitoring software, which reports that port 21 is listening and is not in use. All this is to no avail, as any FTP server software I use still complains that port 21 is already in use. Anyone have any ideas what the problem might be?

Please help

I didn't find the right solution from the internet.

Product demo video production company

The administrator has disabled public write access.
  • Page:
  • 1